FreeBSD VuXML: Documenting security issues in FreeBSD and the FreeBSD Ports Collection

LibYAML input sanitization errors

Affected packages
libyaml < 0.1.6
mingw32-libyaml < 0.1.6


VuXML ID 580cc46b-bb1e-11e3-b144-2c4138874f7d
Discovery 2014-03-11
Entry 2014-03-26

oCERT reports:

The LibYAML project is an open source YAML 1.1 parser and emitter written in C.

The library is affected by a heap-based buffer overflow which can lead to arbitrary code execution. The vulnerability is caused by lack of proper expansion for the string passed to the yaml_parser_scan_uri_escapes() function.

A specially crafted YAML file, with a long sequence of percent-encoded characters in a URL, can be used to trigger the overflow.


CVE Name CVE-2014-2525